Creative Inspire T6160 5.1 Multimedia System subwoofer issue

ilnamiqui
Posts: 1
Joined: Tue Jan 21, 2014 4:38 pm

Re: Creative Inspire T6160 5.1 Multimedia System subwoofer i

Post by ilnamiqui » Tue Jan 21, 2014 5:46 pm

AMAZING !!!!!! IT REALLY WORKS FOR MEE !!!!
THANKS A LOT MAN !!!

segstudent
Posts: 1
Joined: Fri Apr 25, 2014 4:40 am

Re: Creative Inspire T6160 5.1 Multimedia System subwoofer i

Post by segstudent » Fri Apr 25, 2014 5:23 am

Hi, i am facing the same problem with as u guys. i been using them for 2 years and one day the sound fade away and never returned. I have inspected my board and there was no damaged connections or burned components. I even tried to re-solder the connections but still no sound has been produced. Should i just get a new speaker?

egorblack
Posts: 6
Joined: Fri Mar 09, 2012 9:20 am

Re: Creative Inspire T6160 5.1 Multimedia System subwoofer i

Post by egorblack » Tue May 06, 2014 10:15 am

Probably yes, it is not high quality and reliability speakers, also, they are still selling them.

Cassell
Posts: 1
Joined: Fri Aug 10, 2018 2:18 am

Re: Creative Inspire T6160 5.1 Multimedia System subwoofer issue

Post by Cassell » Sat Aug 18, 2018 7:04 am

Is T6160 5.1 Multimedia System subwoofer still the way to go btw? Or is there something better for that price these days?

Johan
Posts: 1
Joined: Wed Nov 07, 2018 3:13 am

Re: Creative Inspire T6160 5.1 Multimedia System subwoofer issue

Post by Johan » Wed Nov 07, 2018 6:35 am

Just wanted to thank you for posting the problem, pics and solution. I've got the same problem with the same model.

Post Reply